Discussion:
[Buildroot] [PATCH v3 1/5] package/efl: switch to luajit support
Romain Naour
2016-06-22 21:27:42 UTC
Permalink
In efl 1.15.x, Lua "old" support is broken with Lua 5.2+ [1].

With the patch added in efl 1.16 to fixes this issue, libevas fail to link with
the following error:

CCLD bin/ecore_evas/ecore_evas_convert
host-efl-1.16.1/src/lib/evas/.libs/libevas.so: undefined reference to `luaL_openlib'
collect2: error: ld returned 1 exit status
Makefile:19021: recipe for target 'bin/ecore_evas/ecore_evas_convert' failed

Since 9ba8d1cce4ab00307827083bae234d87b37fb967, the luajit support can be
enabled in efl package.
In order to update the efl stack to 1.17, switch to luajit support and remove
Lua "old" support since it's not fixed upstream yet. But the drawback is the
efl stack depends implicitely on BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS.

[1] https://phab.enlightenment.org/T2728

Signed-off-by: Romain Naour <***@gmail.com>
---
v2: select BR2_PACKAGE_LUAJIT (ThomasP)
---
package/efl/Config.in | 10 ++++------
package/efl/efl.mk | 17 +++++++++--------
2 files changed, 13 insertions(+), 14 deletions(-)

diff --git a/package/efl/Config.in b/package/efl/Config.in
index 88e2c36..4e37850 100644
--- a/package/efl/Config.in
+++ b/package/efl/Config.in
@@ -2,8 +2,7 @@ config BR2_PACKAGE_EFL
bool "efl"
depends on BR2_INSTALL_LIBSTDCPP
depends on BR2_PACKAGE_HAS_UDEV # libudev
- # https://phab.enlightenment.org/T2728
- depends on BR2_PACKAGE_LUA_5_1 # needs lua 5.1, broken with 5.2+
+ depends on BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS # luajit
depends on BR2_TOOLCHAIN_HAS_THREADS # untested without threads
depends on BR2_USE_MMU
depends on BR2_USE_WCHAR # use wchar_t
@@ -13,6 +12,8 @@ config BR2_PACKAGE_EFL
select BR2_PACKAGE_JPEG # Emile needs libjpeg
select BR2_PACKAGE_LIBCURL # Ecore_con_url, runtime dependency
select BR2_PACKAGE_LIBXKBCOMMON if BR2_PACKAGE_WAYLAND
+ # https://phab.enlightenment.org/T2728
+ select BR2_PACKAGE_LUAJIT # Lua support broken with 5.2+
select BR2_PACKAGE_UTIL_LINUX
# libblkid is part of required tools, see EFL's README.
select BR2_PACKAGE_UTIL_LINUX_LIBBLKID
@@ -184,8 +185,5 @@ endif # BR2_PACKAGE_EFL
comment "efl needs udev /dev management and a toolchain w/ C++, dynamic library, threads, wchar"
depends on !BR2_PACKAGE_HAS_UDEV || !BR2_INSTALL_LIBSTDCPP \
|| BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR
- depends on BR2_USE_MMU
-
-comment "efl needs lua 5.1"
- depends on !BR2_PACKAGE_LUA_5_1
+ depends on BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS
depends on BR2_USE_MMU
diff --git a/package/efl/efl.mk b/package/efl/efl.mk
index 2ea2592..916999d 100644
--- a/package/efl/efl.mk
+++ b/package/efl/efl.mk
@@ -19,8 +19,8 @@ EFL_LICENSE_FILES = \

EFL_INSTALL_STAGING = YES

-EFL_DEPENDENCIES = host-pkgconf host-efl dbus freetype jpeg lua udev \
- util-linux zlib
+EFL_DEPENDENCIES = host-pkgconf host-efl host-luajit dbus freetype \
+ jpeg luajit udev util-linux zlib

# Regenerate the autotools:
# - to fix an issue in eldbus-codegen: https://phab.enlightenment.org/T2718
@@ -29,19 +29,20 @@ EFL_GETTEXTIZE = YES

# Configure options:
# --disable-cxx-bindings: disable C++11 bindings.
+# --disable-lua-old: build elua for the target.
# --disable-sdl: disable sdl2 support.
# --disable-systemd: disable systemd support.
# --disable-xinput22: disable X11 XInput v2.2+ support.
-# --enable-lua-old: disable Elua and remove luajit dependency.
# --with-opengl=none: disable opengl support.
EFL_CONF_OPTS = \
--with-edje-cc=$(HOST_DIR)/usr/bin/edje_cc \
+ --with-elua=$(HOST_DIR)/usr/bin/elua \
--with-eolian-gen=$(HOST_DIR)/usr/bin/eolian_gen \
--disable-cxx-bindings \
+ --disable-lua-old \
--disable-sdl \
--disable-systemd \
--disable-xinput22 \
- --enable-lua-old \
--with-opengl=none

# Disable untested configuration warning.
@@ -227,7 +228,7 @@ $(eval $(autotools-package))
# * host-freetype: for libevas
# * host-libglib2: for libecore
# * host-libjpeg, host-libpng: for libevas image loader
-# * host-lua: disable luajit dependency
+# * host-luajit for Elua tool for the host
HOST_EFL_DEPENDENCIES = \
host-pkgconf \
host-dbus \
@@ -235,7 +236,7 @@ HOST_EFL_DEPENDENCIES = \
host-libglib2 \
host-libjpeg \
host-libpng \
- host-lua \
+ host-luajit \
host-zlib

# Configure options:
@@ -246,10 +247,10 @@ HOST_EFL_DEPENDENCIES = \
# --disable-gstreamer1: remove dependency on gtreamer 1.0.
# --disable-libeeze: remove libudev dependency.
# --disable-libmount: remove dependency on host-util-linux libmount.
+# --disable-lua-old: build elua for the host.
# --disable-physics: remove Bullet dependency.
# --enable-image-loader-gif=no: disable Gif dependency.
# --enable-image-loader-tiff=no: disable Tiff dependency.
-# --enable-lua-old: disable Elua and remove luajit dependency.
# --with-crypto=none: remove dependencies on openssl or gnutls.
# --with-x11=none: remove dependency on X.org.
# Yes I really know what I am doing.
@@ -261,13 +262,13 @@ HOST_EFL_CONF_OPTS += \
--disable-gstreamer1 \
--disable-libeeze \
--disable-libmount \
+ --disable-lua-old \
--disable-multisense \
--disable-physics \
--enable-image-loader-gif=no \
--enable-image-loader-jpeg=yes \
--enable-image-loader-png=yes \
--enable-image-loader-tiff=no \
- --enable-lua-old \
--with-crypto=none \
--with-glib=yes \
--with-opengl=none \
--
2.5.5
Romain Naour
2016-06-22 21:27:43 UTC
Permalink
Update the comment about Lua support which doesn't build with Lua 5.1+.
Update the untested configuration warning option.

Disable efl build for host/target gcc older than 4.7 (oldest tested version).
http://lists.busybox.net/pipermail/buildroot/2016-June/163606.html

Signed-off-by: Romain Naour <***@gmail.com>
---
v3: update to 1.17.2
v2: Remove Ector patch since it's not fixing the build issue reported by
ThomasP.
Add a dependency on gcc >= 4.7.
---
package/efl/Config.in | 7 +++++--
package/efl/efl.hash | 4 ++--
package/efl/efl.mk | 11 +++--------
3 files changed, 10 insertions(+), 12 deletions(-)

diff --git a/package/efl/Config.in b/package/efl/Config.in
index 4e37850..7014e66 100644
--- a/package/efl/Config.in
+++ b/package/efl/Config.in
@@ -1,5 +1,7 @@
config BR2_PACKAGE_EFL
bool "efl"
+ depends on BR2_HOST_GCC_AT_LEAST_4_7 # g++ issue with 4.4.5, tested with g++ 4.7.2
+ depends on BR2_TOOLCHAIN_GCC_AT_LEAST_4_7
depends on BR2_INSTALL_LIBSTDCPP
depends on BR2_PACKAGE_HAS_UDEV # libudev
depends on BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS # luajit
@@ -13,7 +15,7 @@ config BR2_PACKAGE_EFL
select BR2_PACKAGE_LIBCURL # Ecore_con_url, runtime dependency
select BR2_PACKAGE_LIBXKBCOMMON if BR2_PACKAGE_WAYLAND
# https://phab.enlightenment.org/T2728
- select BR2_PACKAGE_LUAJIT # Lua support broken with 5.2+
+ select BR2_PACKAGE_LUAJIT # Lua support broken
select BR2_PACKAGE_UTIL_LINUX
# libblkid is part of required tools, see EFL's README.
select BR2_PACKAGE_UTIL_LINUX_LIBBLKID
@@ -182,8 +184,9 @@ config BR2_PACKAGE_EFL_WEBP

endif # BR2_PACKAGE_EFL

-comment "efl needs udev /dev management and a toolchain w/ C++, dynamic library, threads, wchar"
+comment "efl needs udev /dev management and a toolchain w/ C++, dynamic library, gcc >= 4.7, threads, wchar"
depends on !BR2_PACKAGE_HAS_UDEV || !BR2_INSTALL_LIBSTDCPP \
+ || !BR2_HOST_GCC_AT_LEAST_4_7 || !BR2_TOOLCHAIN_GCC_AT_LEAST_4_7 \
|| BR2_STATIC_LIBS || !BR2_TOOLCHAIN_HAS_THREADS || !BR2_USE_WCHAR
depends on BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS
depends on BR2_USE_MMU
diff --git a/package/efl/efl.hash b/package/efl/efl.hash
index 6673bb5..2ddc005 100644
--- a/package/efl/efl.hash
+++ b/package/efl/efl.hash
@@ -1,2 +1,2 @@
-# From https://download.enlightenment.org/rel/libs/efl/efl-1.15.3.tar.xz.sha256
-sha256 3bac40e6294288034bd7f8902088bf1169cf376f6fd25b7a49854ab561630642 efl-1.15.3.tar.xz
+# From https://download.enlightenment.org/rel/libs/efl/efl-1.17.2.tar.xz.sha256
+sha256 9aa93ff0ab4bdf95d5cf9606bd7efece611691ca22eb6fc3484fe6e7a92bf8b6 efl-1.17.2.tar.xz
diff --git a/package/efl/efl.mk b/package/efl/efl.mk
index 916999d..fd06246 100644
--- a/package/efl/efl.mk
+++ b/package/efl/efl.mk
@@ -4,7 +4,7 @@
#
################################################################################

-EFL_VERSION = 1.15.3
+EFL_VERSION = 1.17.2
EFL_SOURCE = efl-$(EFL_VERSION).tar.xz
EFL_SITE = http://download.enlightenment.org/rel/libs/efl
EFL_LICENSE = BSD-2c, LGPLv2.1+, GPLv2+
@@ -22,11 +22,6 @@ EFL_INSTALL_STAGING = YES
EFL_DEPENDENCIES = host-pkgconf host-efl host-luajit dbus freetype \
jpeg luajit udev util-linux zlib

-# Regenerate the autotools:
-# - to fix an issue in eldbus-codegen: https://phab.enlightenment.org/T2718
-EFL_AUTORECONF = YES
-EFL_GETTEXTIZE = YES
-
# Configure options:
# --disable-cxx-bindings: disable C++11 bindings.
# --disable-lua-old: build elua for the target.
@@ -47,7 +42,7 @@ EFL_CONF_OPTS = \

# Disable untested configuration warning.
ifeq ($(BR2_PACKAGE_EFL_HAS_RECOMMENDED_CONFIG),)
-EFL_CONF_OPTS += --enable-i-really-know-what-i-am-doing-and-that-this-will-probably-break-things-and-i-will-fix-them-myself-and-send-patches-aba
+EFL_CONF_OPTS += --enable-i-really-know-what-i-am-doing-and-that-this-will-probably-break-things-and-i-will-fix-them-myself-and-send-patches-abb
endif

ifeq ($(BR2_PACKAGE_UTIL_LINUX_LIBMOUNT),y)
@@ -273,6 +268,6 @@ HOST_EFL_CONF_OPTS += \
--with-glib=yes \
--with-opengl=none \
--with-x11=none \
- --enable-i-really-know-what-i-am-doing-and-that-this-will-probably-break-things-and-i-will-fix-them-myself-and-send-patches-aba
+ --enable-i-really-know-what-i-am-doing-and-that-this-will-probably-break-things-and-i-will-fix-them-myself-and-send-patches-abb

$(eval $(host-autotools-package))
--
2.5.5
Thomas Petazzoni
2016-06-26 19:33:56 UTC
Permalink
Hello,
Post by Romain Naour
- select BR2_PACKAGE_LUAJIT # Lua support broken with 5.2+
+ select BR2_PACKAGE_LUAJIT # Lua support broken
This change really belongs with the first patch, so I moved it to the
first patch, for consistency.

Thanks,

Thomas
--
Thomas Petazzoni, CTO, Free Electrons
Embedded Linux, Kernel and Android engineering
http://free-electrons.com
Romain Naour
2016-06-26 19:44:40 UTC
Permalink
Hi Thomas,
Post by Thomas Petazzoni
Hello,
Post by Romain Naour
- select BR2_PACKAGE_LUAJIT # Lua support broken with 5.2+
+ select BR2_PACKAGE_LUAJIT # Lua support broken
This change really belongs with the first patch, so I moved it to the
first patch, for consistency.
I meant that the Lua support is not entirely broken with efl 1.15 and completely
broken since 1.16. But ok :)

Tanks for merging the series, I'll monitor the autobuilders to fix build failure
(if any) before sending the next one.

Best regards,
Romain
Post by Thomas Petazzoni
Thanks,
Thomas
Romain Naour
2016-06-22 21:27:44 UTC
Permalink
There is no elementary 1.17.2 release since there was no patch to
backport from upstream.

Signed-off-by: Romain Naour <***@gmail.com>
---
Note: elementary has been merged within efl tree for 1.18 release,
this package will be removed with the next efl update.
---
package/elementary/elementary.hash | 4 ++--
package/elementary/elementary.mk | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/package/elementary/elementary.hash b/package/elementary/elementary.hash
index ecdbc8e..f173752 100644
--- a/package/elementary/elementary.hash
+++ b/package/elementary/elementary.hash
@@ -1,2 +1,2 @@
-# From https://download.enlightenment.org/rel/libs/elementary/elementary-1.15.3.tar.xz.sha256
-sha256 474a9175061021ce8cbcfdbde6162316fc0d927b21118d1ab549377ebc802a93 elementary-1.15.3.tar.xz
+# From https://download.enlightenment.org/rel/libs/elementary/elementary-1.17.1.tar.xz.sha256
+sha256 85e116a453a8ac23da878670534c6292832756d2f3a33603278486f309963d91 elementary-1.17.1.tar.xz
diff --git a/package/elementary/elementary.mk b/package/elementary/elementary.mk
index 7de0c7b..33d4034 100644
--- a/package/elementary/elementary.mk
+++ b/package/elementary/elementary.mk
@@ -4,7 +4,7 @@
#
################################################################################

-ELEMENTARY_VERSION = 1.15.3
+ELEMENTARY_VERSION = 1.17.1
ELEMENTARY_SOURCE = elementary-$(ELEMENTARY_VERSION).tar.xz
ELEMENTARY_SITE = http://download.enlightenment.org/rel/libs/elementary
ELEMENTARY_LICENSE = LGPLv2.1
--
2.5.5
Romain Naour
2016-06-22 21:27:45 UTC
Permalink
Signed-off-by: Romain Naour <***@gmail.com>
---
Note: libevas-generic-loaders has been merged within efl tree for 1.18
release, this package will be removed with the next efl update.
---
package/libevas-generic-loaders/libevas-generic-loaders.hash | 4 ++--
package/libevas-generic-loaders/libevas-generic-loaders.mk | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/package/libevas-generic-loaders/libevas-generic-loaders.hash b/package/libevas-generic-loaders/libevas-generic-loaders.hash
index 32723ba..ee2ae9b 100644
--- a/package/libevas-generic-loaders/libevas-generic-loaders.hash
+++ b/package/libevas-generic-loaders/libevas-generic-loaders.hash
@@ -1,2 +1,2 @@
-# From https://download.enlightenment.org/rel/libs/evas_generic_loaders/evas_generic_loaders-1.15.0.tar.xz.sha256
-sha256 1e539e4d4d4e1590345caeb7fdd84f47ec7cd63bb76b6b7107a87420a401fd7f evas_generic_loaders-1.15.0.tar.xz
+# From https://download.enlightenment.org/rel/libs/evas_generic_loaders/evas_generic_loaders-1.17.0.tar.xz.sha256
+sha256 c2f5193a9326532d3ab3ff76f547b9d17b33ae7221ce4d6e0aefb905ba0dd87a evas_generic_loaders-1.17.0.tar.xz
diff --git a/package/libevas-generic-loaders/libevas-generic-loaders.mk b/package/libevas-generic-loaders/libevas-generic-loaders.mk
index ff8ea37..abc436b 100644
--- a/package/libevas-generic-loaders/libevas-generic-loaders.mk
+++ b/package/libevas-generic-loaders/libevas-generic-loaders.mk
@@ -4,7 +4,7 @@
#
################################################################################

-LIBEVAS_GENERIC_LOADERS_VERSION = 1.15.0
+LIBEVAS_GENERIC_LOADERS_VERSION = 1.17.0
LIBEVAS_GENERIC_LOADERS_SOURCE = evas_generic_loaders-$(LIBEVAS_GENERIC_LOADERS_VERSION).tar.xz
LIBEVAS_GENERIC_LOADERS_SITE = http://download.enlightenment.org/rel/libs/evas_generic_loaders
LIBEVAS_GENERIC_LOADERS_LICENSE = GPLv2
--
2.5.5
Romain Naour
2016-06-22 21:27:46 UTC
Permalink
Signed-off-by: Romain Naour <***@gmail.com>
---
v2: bump to 0.20.9
---
package/enlightenment/enlightenment.hash | 4 ++--
package/enlightenment/enlightenment.mk | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/package/enlightenment/enlightenment.hash b/package/enlightenment/enlightenment.hash
index 66bdb49..fad14b7 100644
--- a/package/enlightenment/enlightenment.hash
+++ b/package/enlightenment/enlightenment.hash
@@ -1,2 +1,2 @@
-# From https://phab.enlightenment.org/phame/live/3/post/e19_14_release/
-sha256 8906e762f0d953752bfe002663280a855da9bb74acf613424c517b78a8dde407 enlightenment-0.19.14.tar.xz
+# From https://www.enlightenment.org/news/e-0.20.9-release
+sha256 db792ad4d97b2523ff0bfc2c911bb3fea4b1eda60400871f4b78bc3ae2f1d1be enlightenment-0.20.9.tar.xz
diff --git a/package/enlightenment/enlightenment.mk b/package/enlightenment/enlightenment.mk
index a756361..6fe8f45 100644
--- a/package/enlightenment/enlightenment.mk
+++ b/package/enlightenment/enlightenment.mk
@@ -4,7 +4,7 @@
#
################################################################################

-ENLIGHTENMENT_VERSION = 0.19.14
+ENLIGHTENMENT_VERSION = 0.20.9
ENLIGHTENMENT_SOURCE = enlightenment-$(ENLIGHTENMENT_VERSION).tar.xz
ENLIGHTENMENT_SITE = http://download.enlightenment.org/rel/apps/enlightenment
ENLIGHTENMENT_LICENSE = BSD-2c
--
2.5.5
Romain Naour
2016-06-26 18:39:10 UTC
Permalink
Hi Gustavo,

I tried to build enlightenment 0.20.9 with Wayland support only but there are
several issues which should be fixed with the next version (0.21)

First we need [1] since configure always check for ecore-x (X11).

Then, there is another issue with Wayland EGL cflags not forwarded correctly
(MESA_EGL_NO_X11_HEADERS not set when EGL/eglplatform.h is included)...

sysroot/usr/include/EGL/eglplatform.h:119:22: fatal error: X11/Xlib.h: No such
file or directory

So, I don't think Wayland support is ready for this version. Instead we should
wait for E 0.21 (rc1 currently).

Also, I have another series (needed for Wayland) adding OpenGL/OpenGLES support,
libdrm for DRM, and DRM + GL support. To finish, I need to add systemd support
in EFL and E.
But this bump series must be commited before sending it ;)

Did you already tested Wayland/Weston with systemd?
Have you a working Buildroot configuration?

Thanks,
Best regards,
Romain

[1]
https://git.enlightenment.org/core/enlightenment.git/commit/?id=a5a27dee14839ed38b078126557cf4c20f1e6b98
Post by Romain Naour
---
v2: bump to 0.20.9
---
package/enlightenment/enlightenment.hash | 4 ++--
package/enlightenment/enlightenment.mk | 2 +-
2 files changed, 3 insertions(+), 3 deletions(-)
diff --git a/package/enlightenment/enlightenment.hash b/package/enlightenment/enlightenment.hash
index 66bdb49..fad14b7 100644
--- a/package/enlightenment/enlightenment.hash
+++ b/package/enlightenment/enlightenment.hash
@@ -1,2 +1,2 @@
-# From https://phab.enlightenment.org/phame/live/3/post/e19_14_release/
-sha256 8906e762f0d953752bfe002663280a855da9bb74acf613424c517b78a8dde407 enlightenment-0.19.14.tar.xz
+# From https://www.enlightenment.org/news/e-0.20.9-release
+sha256 db792ad4d97b2523ff0bfc2c911bb3fea4b1eda60400871f4b78bc3ae2f1d1be enlightenment-0.20.9.tar.xz
diff --git a/package/enlightenment/enlightenment.mk b/package/enlightenment/enlightenment.mk
index a756361..6fe8f45 100644
--- a/package/enlightenment/enlightenment.mk
+++ b/package/enlightenment/enlightenment.mk
@@ -4,7 +4,7 @@
#
################################################################################
-ENLIGHTENMENT_VERSION = 0.19.14
+ENLIGHTENMENT_VERSION = 0.20.9
ENLIGHTENMENT_SOURCE = enlightenment-$(ENLIGHTENMENT_VERSION).tar.xz
ENLIGHTENMENT_SITE = http://download.enlightenment.org/rel/apps/enlightenment
ENLIGHTENMENT_LICENSE = BSD-2c
Gustavo Zacarias
2016-06-26 19:20:27 UTC
Permalink
Post by Romain Naour
Hi Gustavo,
I tried to build enlightenment 0.20.9 with Wayland support only but there are
several issues which should be fixed with the next version (0.21)
First we need [1] since configure always check for ecore-x (X11).
Hi Romain.
Yes, that's a typical failure in some packages, particularly gtk3-using
ones that assume X must be around and break wayland & broadway.
Post by Romain Naour
Then, there is another issue with Wayland EGL cflags not forwarded correctly
(MESA_EGL_NO_X11_HEADERS not set when EGL/eglplatform.h is included)...
sysroot/usr/include/EGL/eglplatform.h:119:22: fatal error: X11/Xlib.h: No such
file or directory
This is typically a problem with pkg-config files missing EGL cflags,
such as in libepoxy:
https://git.busybox.net/buildroot/tree/package/libepoxy/0005-Forward-egl-cflags-into-epoxy.pc.patch
Hence for example mesa headers go crazy and that happens.
Post by Romain Naour
So, I don't think Wayland support is ready for this version. Instead we should
wait for E 0.21 (rc1 currently).
Also, I have another series (needed for Wayland) adding OpenGL/OpenGLES support,
libdrm for DRM, and DRM + GL support. To finish, I need to add systemd support
in EFL and E.
But this bump series must be commited before sending it ;)
Did you already tested Wayland/Weston with systemd?
Have you a working Buildroot configuration?
Not yet, i've paved the way to make that simpler in weston via
automatically enabling systemd bindings and the helper, but i haven't
runtime tested it since my samples aim for total simplicity hence start
everything up as root automatically via initscript (no extra user
accounts and so on) - and normally doing this on a systemd target isn't
so simple.
Regards.
Romain Naour
2016-07-01 07:26:46 UTC
Permalink
Hi Gustavo,
Post by Gustavo Zacarias
Post by Romain Naour
Hi Gustavo,
I tried to build enlightenment 0.20.9 with Wayland support only but there are
several issues which should be fixed with the next version (0.21)
First we need [1] since configure always check for ecore-x (X11).
Hi Romain.
Yes, that's a typical failure in some packages, particularly gtk3-using ones
that assume X must be around and break wayland & broadway.
Post by Romain Naour
Then, there is another issue with Wayland EGL cflags not forwarded correctly
(MESA_EGL_NO_X11_HEADERS not set when EGL/eglplatform.h is included)...
sysroot/usr/include/EGL/eglplatform.h:119:22: fatal error: X11/Xlib.h: No such
file or directory
This is typically a problem with pkg-config files missing EGL cflags, such as in
https://git.busybox.net/buildroot/tree/package/libepoxy/0005-Forward-egl-cflags-into-epoxy.pc.patch
Hence for example mesa headers go crazy and that happens.
Post by Romain Naour
So, I don't think Wayland support is ready for this version. Instead we should
wait for E 0.21 (rc1 currently).
Also, I have another series (needed for Wayland) adding OpenGL/OpenGLES support,
libdrm for DRM, and DRM + GL support. To finish, I need to add systemd support
in EFL and E.
But this bump series must be commited before sending it ;)
Did you already tested Wayland/Weston with systemd?
Have you a working Buildroot configuration?
Not yet, i've paved the way to make that simpler in weston via automatically
enabling systemd bindings and the helper, but i haven't runtime tested it since
my samples aim for total simplicity hence start everything up as root
automatically via initscript (no extra user accounts and so on) - and normally
doing this on a systemd target isn't so simple.
Regards.
Ok tanks for your feedback :)

E 0.21.0 has been released yesterday but for wayland only build we need
ecore-wl2 library from efl git master (i.e 1.18) [1].
I don't think efl 1.18 will be released before 2016.08-rc1, so I'll keep E
0.20.x for now.

If I have some time, I'll work on OpenGL/OpenGLES and systemd support with the
current version.

Best regards,

[1]
https://git.enlightenment.org/core/enlightenment.git/commit/?id=03f3297b3c5c7e7f18c422cd5e1fc19987959aa8
Post by Gustavo Zacarias
_______________________________________________
buildroot mailing list
http://lists.busybox.net/mailman/listinfo/buildroot
Thomas Petazzoni
2016-06-26 19:33:23 UTC
Permalink
Hello,
Post by Romain Naour
In efl 1.15.x, Lua "old" support is broken with Lua 5.2+ [1].
With the patch added in efl 1.16 to fixes this issue, libevas fail to link with
CCLD bin/ecore_evas/ecore_evas_convert
host-efl-1.16.1/src/lib/evas/.libs/libevas.so: undefined reference to `luaL_openlib'
collect2: error: ld returned 1 exit status
Makefile:19021: recipe for target 'bin/ecore_evas/ecore_evas_convert' failed
Since 9ba8d1cce4ab00307827083bae234d87b37fb967, the luajit support can be
enabled in efl package.
In order to update the efl stack to 1.17, switch to luajit support and remove
Lua "old" support since it's not fixed upstream yet. But the drawback is the
efl stack depends implicitely on BR2_PACKAGE_LUAJIT_ARCH_SUPPORTS.
[1] https://phab.enlightenment.org/T2728
Entire series applied, thanks! I just did a minor change, I'll reply to
the specific patch.

Thomas
--
Thomas Petazzoni, CTO, Free Electrons
Embedded Linux, Kernel and Android engineering
http://free-electrons.com
Continue reading on narkive:
Loading...