Discussion:
[PATCH] confifs/aarch64_efi: needs dosfstools
(too old to reply)
Yann E. MORIN
2018-12-09 10:35:56 UTC
Permalink
Fixes:
https://gitlab.com/ymorin/buildroot/-/jobs/131924126

Signed-off-by: "Yann E. MORIN" <***@free.fr>
Cc: Erico Nunes <***@gmail.com>
Cc: Thomas Petazzoni <***@bootlin.com>
---
configs/aarch64_efi_defconfig | 3 +++
1 file changed, 3 insertions(+)

diff --git a/configs/aarch64_efi_defconfig b/configs/aarch64_efi_defconfig
index ecc050fc5e..1c918e2a4f 100644
--- a/configs/aarch64_efi_defconfig
+++ b/configs/aarch64_efi_defconfig
@@ -32,3 +32,6 @@ BR2_LINUX_KERNEL_CUSTOM_VERSION=y
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.18.10"
BR2_LINUX_KERNEL_USE_ARCH_DEFAULT_CONFIG=y
BR2_LINUX_KERNEL_NEEDS_HOST_OPENSSL=y
+
+# Host tools for genimage
+BR2_PACKAGE_HOST_DOSFSTOOLS=y
--
2.14.1
Thomas Petazzoni
2018-12-09 13:27:25 UTC
Permalink
Hello,
Post by Yann E. MORIN
https://gitlab.com/ymorin/buildroot/-/jobs/131924126
---
configs/aarch64_efi_defconfig | 3 +++
1 file changed, 3 insertions(+)
diff --git a/configs/aarch64_efi_defconfig b/configs/aarch64_efi_defconfig
index ecc050fc5e..1c918e2a4f 100644
--- a/configs/aarch64_efi_defconfig
+++ b/configs/aarch64_efi_defconfig
@@ -32,3 +32,6 @@ BR2_LINUX_KERNEL_CUSTOM_VERSION=y
BR2_LINUX_KERNEL_CUSTOM_VERSION_VALUE="4.18.10"
BR2_LINUX_KERNEL_USE_ARCH_DEFAULT_CONFIG=y
BR2_LINUX_KERNEL_NEEDS_HOST_OPENSSL=y
+
+# Host tools for genimage
+BR2_PACKAGE_HOST_DOSFSTOOLS=y
You also needs mtools for genimage to support creating a FAT filesystem.

Best regards,

Thomas
--
Thomas Petazzoni, CTO, Bootlin
Embedded Linux and Kernel engineering
https://bootlin.com
Loading...